ID #1041

Workaround til MIDI feedback problem ved Multiout instrumenter.

Jeg ved ikke hvorfor det tog mig så lang tid. Selvom den var til at overse har løsningen alligevel ligget lige for hele tiden, men der er heller ikke andre der har postet løsningen så jeg er nok ikke den eneste der ikke fik øje på den med det samme.

Problem:

Multiinstrumenter har det problem at når man inserter I/O pluginnet på en af de Aux'er der skabes når man benytter sig af multi-output featuren og stiller sig på et andet spor en selve multiinstrumentets spor i arrange, så opstår der noget feedback af en art. Jeg har hørt det omtalt som "MIDI loopback" o.a. Det gør I/O pluginnet praktisk talt umuligt at benytte på multiinstrumenter.

For mig, som næsten udelukkende processerer med hardware og benytter I/O pluginnet i ét væk, er det naturligvis fantastisk irriterende når jeg bruger f.eks. EZ Drummer.

Jeg gik igennem forskellige muligheder med eventuelt at bounce de forskellige outputs og så processere de resulterende audiofiler og jeg har overvejet forskellige andre alternativer. Alle resulterede i at jeg ikke kunne arbejde realtime på hele trommesættet inkl. at programmere og lave lyd på tingene, og dét er jo helt mongo hvis man ikke skulle kunne det i dag... Og Apple har åbenbart ikke tænkt sig at vi skal hjælpes alt for meget i denne retning. Det var også et problem i 8 og er heller ikke rettet nu i 9.1.

Løsning:

Som sagt er det helt åbenlyst når man nu ser det, men det tog mig fa'me lang tid at hitte på det... Man outputter selvfølgelig bare sine multiouts til busser og dermed nye aux'er og inserter sine plugins dér. Det er selvfølgelig en lille ekstra operation og opsætning man skal igennem men det er hurtigt overstået og så fungerer det bare helt problemfrit som det skal:

(Lyd: http://dl.dropbox.com/u/1683654/MultiOut_Fixed.mp3 )

Billede 10.png

PS: Og det fik mig så til at komme i tanker om en lille bonusløsning på et andet problem.

Når man trykker mono på de aux'er EZ Drummer laver så bliver de kanaler inaktive og så kan man kun bruge stereoplugins eller man må snørkle sig til en anden måde at få insertet f.eks. en monocompressor på en lille tromme.

På de nye Aux'er som min workaround indebærer trykker man jo i stedet bare mono som normalt og arbejder som man vil. Det er jo en løsning oven i løsningen som er ret nice faktisk.

Tags: -

Related entries:

You cannot comment on this entry